|View Issue Details [ Jump to Notes ] ||[ Issue History ] [ Print ] |
|ID||Project||Category||View Status||Date Submitted||Last Update|
|0000010||124thATC||[All Projects] General||public||2015-08-25 03:35||2016-11-22 05:46|
|Assigned To||ntnll|| |
|Platform||x64||OS||Linux||OS Version||Ubuntu 14.04 LTS|
|Product Version||2.0-a11|| |
|Target Version||Fixed in Version||2.0-a12|| |
|Summary||0000010: Plugin compiled against too recent libstdc++|
|Description||Plugin expects external library referencing GLIBCXX_3.4.20 which is provided by libstdc++.so.6.0.20 and higher.|
As of today, latest long-term support of Ubuntu is 14.04 (next will be 16.04) and is using libstdc++.so.6.0.19. This applies to its derivatives too.
Steam users are using libstdc++.so.6.0.18 which is provided by Steam itself.
In both cases the required library is not easily available for users, who will struggle for satisfying the dependency. In addition, the way to fix the issue on the user side depends on the install (Steam or not).
|Additional Information||Recommendation is to link against libstdc++.so.6.0.18 so both Steam and non-Steam users have no dependency issue (providing the later are at least with Ubuntu/derivative 14.04 or more recent).|
Alternative would be to link with rpath option and ship the lib together with the plugin. This should however reserved in cases where a strict or very recent version of a library is required.
|Tags||No tags attached.|