View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000010124thATC[All Projects] Generalpublic2015-08-25 03:352016-11-22 05:46
Assigned Tontnll 
Platformx64OSLinuxOS VersionUbuntu 14.04 LTS
Product Version2.0-a11 
Target VersionFixed in Version2.0-a12 
Summary0000010: Plugin compiled against too recent libstdc++
DescriptionPlugin expects external library referencing GLIBCXX_3.4.20 which is provided by and higher.

As of today, latest long-term support of Ubuntu is 14.04 (next will be 16.04) and is using This applies to its derivatives too.
Steam users are using which is provided by Steam itself.

In both cases the required library is not easily available for users, who will struggle for satisfying the dependency. In addition, the way to fix the issue on the user side depends on the install (Steam or not).
Additional InformationRecommendation is to link against so both Steam and non-Steam users have no dependency issue (providing the later are at least with Ubuntu/derivative 14.04 or more recent).

Alternative would be to link with rpath option and ship the lib together with the plugin. This should however reserved in cases where a strict or very recent version of a library is required.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2015-08-25 03:35 yoyoz New Issue
2015-08-25 11:19 ntnll Status new => assigned
2015-08-25 11:19 ntnll Assigned To => ntnll
2015-08-27 10:07 ntnll Status assigned => resolved
2015-08-27 10:07 ntnll Resolution open => fixed
2015-08-27 10:58 ntnll Fixed in Version => 2.0-a12
2016-11-22 05:46 ntnll Status resolved => closed

Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker