MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000188124thATC[All Projects] En routepublic2016-04-10 22:342016-11-22 05:45
ReporterAdvMichael 
Assigned Tontnll 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platformx64OS(All OS)OS Version(All versions)
Product Version2.0-a36 
Target VersionFixed in Version2.0-a42 
Summary0000188: Handover to approach not working if approach frequency is same as tower frequency (origin or destination)
DescriptionDuring island hopping on Greek Islands I noticed a problem with the handover to approach. After getting instruction to contact approach, I confirmed the instruction and changed to approach frequency. The "Approach initial call" button appeared, but when clicking it, the button disappeared and nothing happened. For more details see the log with comments in "Additional Information".

Looking into that issue and trying several configurations I found out, that this problem happens in following two different situations:
1) if the approach frequency is same as the tower frequency of DEPARTURE airport
OR
2) if the approach frequency is same as the tower frequency of DESTINATION airport

Possible solutions:

a) Once handed over from tower (departure airport) to center, the old tower frequency should be ignored, unless you declare emergency and return to the departure airport
b) if the approach frequency is same as the destination airport tower frequency, maybe some different approach frequency can be generated (same as with no approach frequency available).
Steps To ReproduceFlight from LGKO to LGSR at 4000ft
Please note, that this is a short flight and the airports are not to far from each other, which might be another root cause for this problem to appear.

TEST 1 (arrival frequency is same as tower frequency of DESTINATION airport)
LGKO TWR = 122.10 (default configuration) [DEPARTURE AIRPORT]
LGSR APP = 118.05 (default configuration)
LGSR TWR = 118.05 (default configuration)
--> handover to approach not working

TEST 2 (arrival frequency is same as tower frequency of DEPARTURE airport)
LGKO TWR = 122.10 (default configuration) [DEPARTURE AIRPORT]
LGSR APP = 122.10 (changed in apt.dat as this is the published alternative APP)
LGSR TWR = 118.05 (default configuration)
--> handover to approach not working

TEST 3 (arrival frequency NOT same as any tower frequency)
LGKO TWR = 122.10 (default configuration) [DEPARTURE AIRPORT]
LGSR APP = 124.50 (changed in apt.dat to this fictional frequency)
LGSR TWR = 118.05 (default configuration)
--> WITH THIS CONFIGURATION THE PROBLEM DOES NOT HAPPEN BECAUSE THE APPROACH FREQUENCY IS DIFFERENY FROM ANY TOWER FREQUENCY AVAILABLE
Additional Information124thATC v2.0-a36 18:33:23 : Communication: D-EHFD, turn right heading 204.
124thATC v2.0-a36 18:33:31 : Communication: turn right heading 204, D-EHFD
124thATC v2.0-a36 18:34:14 : reading acc.dat
124thATC v2.0-a36 18:34:57 : Communication: D-EHFD, QNH 1005, contact Santorini approach on 122.10. Expect runway 34R to land, bye.
124thATC v2.0-a36 18:35:21 : Communication: QNH 1005, contact Santorini approach on 122.10, runway 34R to land, good bye, D-EHFD.
--> after changing the frequency you get the "Approach initial call" button
--> you can press it, is disappears, but nothing happens
--> after some time the windows opens again, but if you press the button "Approach initial call" again nothing happens again
--> please note, that the window has the title "Tower" (actually it should be "Approach"), so that made obvious, that there is some conflict with any tower frequencies
124thATC v2.0-a36 18:36:04 : gIsCopiing reset!
124thATC v2.0-a36 18:37:25 : gIsCopiing reset!
124thATC v2.0-a36 18:38:16 : gIsCopiing reset!
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000074)
AdvMichael (reporter)
2016-04-29 21:25

Faced a similar problem today on a flight from EDDN to EHAM. The handover to approach was working properly, however, I could not contact tower after established on the ILS. The reason here also might be a same frequency at destination and arrival airports.
EDDN ground: 118.1
EHAM tower: 118.1
Seems the plugin faces problems, if any frequency is same at origin and destination airport.
(0000075)
ntnll (administrator)
2016-08-01 16:19

Hi Michael,
as always, I'm surprised with your speed in founding and isolating the issues. Thank you for report it.
I already knew this bug, but I'm not pretty sure if is a plugin bug, or a incorrect implementation of wed frequencies.

Maybe it means that the two controls are provided by the same entity. I'm not sure but if a control is not available, it should be set to 0.00, and not equal to another control frequency. I don't know how it is handled in the real word, I'll try to ask to a real controller, and also check the original laminar airports configurations.

(0000076)
ntnll (administrator)
2016-08-01 16:46

Solved skipping approach handover phase, like when it is unavailable, when tower and approach destination frequencies are the same.
Waiting to better understand the real world behavior.

- Issue History
Date Modified Username Field Change
2016-04-10 22:34 AdvMichael New Issue
2016-04-29 21:25 AdvMichael Note Added: 0000074
2016-08-01 16:19 ntnll Note Added: 0000075
2016-08-01 16:19 ntnll Status new => confirmed
2016-08-01 16:19 ntnll Resolution open => suspended
2016-08-01 16:46 ntnll Note Added: 0000076
2016-08-01 16:46 ntnll Status confirmed => resolved
2016-08-01 16:46 ntnll Resolution suspended => fixed
2016-08-01 16:46 ntnll Fixed in Version => 2.0-a42
2016-08-08 02:30 ntnll Status resolved => assigned
2016-08-08 02:30 ntnll Assigned To => ntnll
2016-08-08 02:54 ntnll Status assigned => resolved
2016-11-22 05:45 ntnll Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker