MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000023124thATC[All Projects] Generalpublic2015-08-26 19:312016-11-22 05:46
ReporterHovercat 
Assigned Tontnll 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platformx64OSWindowsOS Version(All versions)
Product Version2.0-a11 
Target VersionFixed in Version2.0-a13 
Summary0000023: Too many heading instructions
DescriptionMost of the time, when you are on the airway, on your route, the ATC does not issue a new heading after each waypoint. Only in the beginning to get to the first waypoint, or when you are far away from your route, the ATC issues a heading.

Also its a little sensitive. When i press "direct" button on FMC (after ATC tells me to "fly 321 to XXXXX", so to get to the first waypoint in flight plan) ATC still wants to correct me! Maybe the wind calculation plays into it? Maybe you can use true heading as a dataref, to see if plane flies to waypoint?
Steps To ReproduceIn initial climb, after ATC issues first heading to your first waypoint, press direct button on your FMC.
Have realy world weather on with winds. (I use NOAA weather plugin by the way. Maybe thats an issue, that this plugin is reporting other winds than normal x-plane weather?)
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000003)
ntnll (administrator)
2015-09-04 19:05

Hi Hovercat,
I'm not able to replicate the issue.

I have removed the message issued by the button, now in 2.0-a13 version,, when you press "direct to" a new waypoint, plugin only switchs to new fix, no more messages will be displayed. Next message will be the normal heading correction to new waypoint. Maybe this change can solve your issue. Please try version linked below (overwrite your win.xpl) and if the problem is still present, you should be explain me one more time how replicate issue. I'm not facing too many heading instruction. Please try also, before report, disable and enable WCA and your weather engine. Also take a look to on screen informations to see heading corrections.

https://www.dropbox.com/s/fhk722ipf3s29jo/win.xpl?dl=0 [^]

Thanks
antonello
(0000004)
ntnll (administrator)
2015-09-10 11:21

Added a max heading error tollereance option

- Issue History
Date Modified Username Field Change
2015-08-26 19:31 Hovercat New Issue
2015-08-26 19:38 ntnll Status new => assigned
2015-08-26 19:38 ntnll Assigned To => ntnll
2015-09-04 19:05 ntnll Note Added: 0000003
2015-09-10 11:21 ntnll Note Added: 0000004
2015-09-10 11:21 ntnll Status assigned => resolved
2015-09-10 11:21 ntnll Resolution open => fixed
2015-09-10 11:21 ntnll Fixed in Version => 2.0-a13
2016-11-22 05:46 ntnll Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker