MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000257124thATC[All Projects] Phraseology/Speechpublic2017-03-12 21:302017-07-07 11:31
ReporterAdvMichael 
Assigned Tontnll 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platformx64OSWindowsOS Version(All versions)
Product Version2.0-a53 
Target VersionFixed in Version2.0-a54 
Summary0000257: Plugin doesn't reset TTS "user#" voice after IFR clearance
DescriptionSince the text-to-speech function in X-Plane is also used for ATIS or some checklist readers, we need to make sure to set back the voice to the "user#" selection (pilot voice) after every ATC message, also where no readback is required. Otherwise the voice for the checklist reader changes.

Usually everything works fine, since for most messages 124thATC requires a readback and then automatically changes to the pilot voice ("user#"). However, on some occasions, where no readback is required, this does not happen.

Example: After requesting and getting the IFR clearance, 124thATC finally confirms "... readback correct, contact ground on xxxx when ready for startup". As this Information requires no readback, 124thATC will not switch back to the pilot voice ("user#"). So the checklist reader, which initially started with the pilot voice, will continue with the random picked ATC voice.

At the moment I only noticed that after the IFR request. However, please check the software, if there are any other ATC messages, which also do not require and readback. I also will do more test flight, checking for that issue.

Steps To ReproduceProblem occurs for example right after IFR clearance "... readback correct, contact ground on xxxx when ready for startup", since there no readback is required.
Additional InformationHi Michael,
thanks for report the bug. I just fixed resetting the user voice after IFR clearance. I also noticed only this case, anyway I'll make further checks.
I'm changing the issue summary for better reflect it in change log.

Cheers
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000092)
AdvMichael (updater)
2017-03-19 18:20

After another flight today I can confirm, that this also happens on final approach, when tower says "... identified, continue approach ...", as this also requires no readback.

- Issue History
Date Modified Username Field Change
2017-03-12 21:30 AdvMichael New Issue
2017-03-19 18:20 AdvMichael Note Added: 0000092
2017-04-14 23:24 ntnll Assigned To => ntnll
2017-04-14 23:24 ntnll Status new => resolved
2017-04-14 23:24 ntnll Resolution open => fixed
2017-04-14 23:24 ntnll Fixed in Version => 2.0-a54
2017-04-14 23:24 ntnll Summary TTS voice package should be changed back to "user#" even no readback is required after an ATC message => Plugin doesn't reset TTS "user#" voice after IFR clearance
2017-04-14 23:24 ntnll Additional Information Updated View Revisions
2017-04-14 23:25 ntnll Additional Information Updated View Revisions
2017-07-07 11:31 ntnll Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker