MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000037124thATC[All Projects] En routepublic2015-09-13 14:302016-11-22 05:47
ReporterAdvMichael 
Assigned Tontnll 
PrioritynormalSeveritymajorReproducibilitysometimes
StatusclosedResolutionfixed 
Platformx64OS(All OS)OS Version(All versions)
Product Version2.0-a13 
Target VersionFixed in Version2.0-a15 
Summary0000037: Pressure Altitude support
DescriptionATC is permanently giving altitude correction requests "altitude 300 feet above clearance altitude", even flying the correct flight level and having the altimeter correctly set to 1013hPa above TA. Appears that 124thATC is not considering the transition altitude and flight levels when checking the altitude. The problem appears, when the real weather QNH has a high deviation from standard 1013hPa. At lower deviation the problem also exists, but probably will not show up due to the default "flight level error tolerance 300 feet" setting in the options.
Steps To ReproduceManually set the weather with a QNH 1024 (any higher deviation from standard pressure, below or above 1013hPA will do) and fly for example at planned/cleared FL270. Checking the actual calculation values (CTRL-F11) shows the too high altitude (in this example 27317) which the planned/cleared altitude is compared with. As the value exceeds the set tolerance (300ft in options), ATC will inform you about the too high altitude, which is wrong, as actually you are flying at the correct flight level (with standard pressure set).
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000012)
ntnll (administrator)
2015-09-19 23:43

Dear Micheal,
I can't reproduce issue, but it can be due some fixes I done to 2.0-a15.
I'm going to mark issue as fixed, if the issue will persist in 2.0-a15, we will reopen it.

Bye
a.
(0000013)
ntnll (administrator)
2015-09-24 11:26

Pressure Altitude x-plane dataref is incorrect because still calculates sea level pressure over TA and at high altitudes.
Added function to calculate error delta and correct altitude dataref altitude value over TA

- Issue History
Date Modified Username Field Change
2015-09-13 14:30 AdvMichael New Issue
2015-09-13 23:37 ntnll Assigned To => ntnll
2015-09-13 23:37 ntnll Status new => assigned
2015-09-19 23:43 ntnll Note Added: 0000012
2015-09-19 23:43 ntnll Status assigned => resolved
2015-09-19 23:43 ntnll Resolution open => fixed
2015-09-19 23:43 ntnll Fixed in Version => 2.0-a15
2015-09-24 11:24 ntnll Summary Receiving wrong altitude correction request from ATC => Pressure Altitude bad calculation - receiving wrong altitude correction request from ATC
2015-09-24 11:26 ntnll Note Added: 0000013
2015-10-13 11:24 ntnll Summary Pressure Altitude bad calculation - receiving wrong altitude correction request from ATC => Pressure Altitude support
2016-11-22 05:47 ntnll Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker