MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000099124thATC[All Projects] Departurepublic2015-12-13 00:012016-11-22 05:47
ReporterAdvMichael 
Assigned Tontnll 
PrioritynormalSeverityminorReproducibilitysometimes
StatusclosedResolutionfixed 
Platformx64OS(All OS)OS Version(All versions)
Product Version2.0-a20 
Target VersionFixed in Version2.0-a21 
Summary0000099: Improved SID and STAR support - path is now inserted as fligh plan part
DescriptionEven 124thATC provided the clearance for a certain SID, after takeoff it will still give heading instructions pointing directly to the final point of the SID or first point in the flight plan, ignoring the correct SID route. The logic should be: if ATC provided the clearance using a certain SID, all heading instructions should be disabled until reaching the final SID waypoint.
Steps To ReproduceLSZH departure RW32 on SID GERSA1N (as cleared by ATC)
First waypoint in flight plan: GERSA
Problem: right after takeoff and handover to center 124thATC will request a left turn direct to GERSA, ignoring the SID waypoints.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000028)
ntnll (administrator)
2015-12-17 19:57

Hi Michael,
yes this is know bug. Because I don't even put SID fixes in the flight plan. I'm terminating right now the SID parsing and functions for insert it in flight plan, we will have its availabe on .21.

Also i'm working on little changes to heading vectoring, my goal is reduce it to very minimal calls, I planned to fix this aspect also in .21

Thanks for report
a.

- Issue History
Date Modified Username Field Change
2015-12-13 00:01 AdvMichael New Issue
2015-12-17 19:57 ntnll Note Added: 0000028
2015-12-17 19:57 ntnll Assigned To => ntnll
2015-12-17 19:57 ntnll Status new => confirmed
2015-12-17 19:57 ntnll Resolution open => fixed
2015-12-17 19:57 ntnll Status confirmed => resolved
2015-12-17 19:57 ntnll Fixed in Version => 2.0-a21
2015-12-17 21:52 ntnll Summary Still getting (incorrect) heading instructions during SID => Improved SID support - path is now inserted as fligh plan part
2015-12-22 14:09 ntnll Summary Improved SID support - path is now inserted as fligh plan part => Improved SID and STAR support - path is now inserted as fligh plan part
2016-11-22 05:47 ntnll Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker